openid_client 0.4.3
openid_client: ^0.4.3 copied to clipboard

Library for working with OpenID Connect and implementing clients.

Use this package as an executable

Install it

You can install the package from the command line:

dart pub global activate openid_client

Use it

The package has the following executables:

$ openid_client

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add openid_client

With Flutter:

 $ flutter pub add openid_client

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  openid_client: ^0.4.3

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:openid_client/openid_client.dart';
28
likes
110
pub points
91%
popularity

Publisher

appsup.be

Library for working with OpenID Connect and implementing clients.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

args, http, jose, logging, meta, pointycastle

More

Packages that depend on openid_client