oauth2 1.6.3
oauth2: ^1.6.3 copied to clipboard

Dart native js
Flutter Android iOS Linux macOS web Windows

A client library for authenticating with a remote service via OAuth2 on behalf of a user, and making authorized HTTP requests with the user's OAuth2 credentials.

68
likes
110 / 110
pub points
94 %
popularity

We analyzed this package on Feb 26, 2021, and awarded it 110 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 42 out of 43 API elements (97.7 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
crypto^2.1.32.1.53.0.0
http>=0.11.0 <0.13.00.12.20.13.0
http_parser>=1.0.0 <4.0.03.1.44.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.2.0
collection-1.14.131.15.0
convert-2.1.13.0.0
meta-1.2.41.3.0
path-1.7.01.8.0
source_span-1.7.01.8.1
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.2.01.3.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^2.1.3` on crypto does not support the stable version `3.0.0`, that was published 23 days ago.

When crypto is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions crypto to update the constraint.

The constraint `>=0.11.0 <0.13.0` on http does not support the stable version `0.13.0`, that was published 20 days ago.

When http is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Dart 2.10.5.

68
likes
110
pub points
94%
popularity

A client library for authenticating with a remote service via OAuth2 on behalf of a user, and making authorized HTTP requests with the user's OAuth2 credentials.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploaders

dgrove@google.com
jmesserly@google.com
sigmund@google.com
nweiz@google.com
nbosch@google.com
kevmoo@google.com
jonasfj@google.com

License

BSD (LICENSE)

Dependencies

crypto, http, http_parser

More

Packages that depend on oauth2