moblink 3.3.9

  • Readme
  • Changelog
  • Example
  • Installing
  • 79

MobLink For Flutter #

开始 #

  1. Flutter集成文档 MobLink-For-Flutter 在线文档

  2. iOS平台设置参考iOS集成文档

    • 实现其中的第一点:进行官网后台配置
    • 第三点的第1.2条,URL Scheme和Universal link配置,
    • 第三点的第1.3条,MobAppkey和MobAppsecret的配置。
  3. Android平台设置参考Android集成文档

    • 实现第一点完成官网后台配置
    • 在第二点中的第2条,替换appKey、appSecret为您自己的配置
    • 同时在第二点中的第2条中,需要在MobLink{}内配置以下两项
    • uriScheme "mlink://com.mob.moblink.demo"
    • appLinkHost "z.t4m.cn"
  4. Web平台设置参考Web端集成文档

3.3.9 #

  • TODO: Describe initial release.

example/lib/main.dart

import 'package:flutter/material.dart';
import './home.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(home: HomePage());
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  moblink: ^3.3.9

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:moblink/moblink.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
58
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
79
Learn more about scoring.

We analyzed this package on May 27, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.1
  • pana: 0.13.8-dev
  • Flutter: 1.17.0

Health suggestions

Fix lib/moblink_interface.dart. (-1 points)

Analysis of lib/moblink_interface.dart reported 2 hints:

line 31 col 19: This function has a return type of 'Future

line 95 col 26: Name non-constant identifiers using lowerCamelCase.

Format lib/moblink_defines.dart.

Run flutter format to format lib/moblink_defines.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8