mcg_extension 1.0.1 icon indicating copy to clipboard operation
mcg_extension: ^1.0.1 copied to clipboard

Extension with Appcontroller, OverWidget, Widget Sizer, Restarter, Logger, Hive, Permission Manager, Crypt and more...

0
likes
90/ 140
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 90 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://www.obyazilim.com was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 70 out of 1139 API elements (6.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform Windows.

Because:

  • package:mcg_extension/mcg_extension.dart that imports:
  • package:mcg_extension/validators/validatorrules.dart that imports:
  • package:mcg_extension/get/translate.dart that imports:
  • package:mcg_extension/get/app_controller.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/web/web_helper.dart that imports:
  • package:flutter_cache_manager/src/cache_store.dart that imports:
  • package:flutter_cache_manager/src/config/config.dart that imports:
  • package:flutter_cache_manager/src/config/_config_io.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_object_provider.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.

Package does not support platform Linux.

Because:

  • package:mcg_extension/mcg_extension.dart that imports:
  • package:mcg_extension/validators/validatorrules.dart that imports:
  • package:mcg_extension/get/translate.dart that imports:
  • package:mcg_extension/get/app_controller.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/web/web_helper.dart that imports:
  • package:flutter_cache_manager/src/cache_store.dart that imports:
  • package:flutter_cache_manager/src/config/config.dart that imports:
  • package:flutter_cache_manager/src/config/_config_io.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_object_provider.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.

Package does not support platform macOS.

Because:

  • package:mcg_extension/mcg_extension.dart that imports:
  • package:mcg_extension/permissionmanager/permissionmanagershared.dart that imports:
  • package:mcg_extension/permissionmanager/permissionmanagermobile.dart that imports:
  • package:permission_handler/permission_handler.dart that declares support for platforms: Android, iOS, Windows.

Package does not support platform Web.

Because:

  • package:mcg_extension/mcg_extension.dart that imports:
  • package:mcg_extension/validators/validatorrules.dart that imports:
  • package:mcg_extension/get/translate.dart that imports:
  • package:mcg_extension/get/app_controller.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_info_repositories.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/json_cache_info_repository.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 60 issues. Showing the first 2:

INFO: Unnecessary type check; the result is always 'false'.

lib/crypt/crypt.dart:43:11

   ╷
43 │       if (decrptedData is! String) return null;
   │           ^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/crypt/crypt.dart

INFO: This class (or a class that this class inherits from) is marked as '@immutable', but one or more of its instance fields aren't final: BottomSheetPanel.barrierDismissible

lib/over/bottomsheet_dialog/bottomsheetpanel.dart:19:7

   ╷
19 │ class BottomSheetPanel extends StatelessWidget implements IPanel {
   │       ^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/over/bottomsheet_dialog/bottomsheetpanel.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
animated^2.0.02.0.02.0.0
auto_size_text^3.0.03.0.03.0.0
avatar_glow^2.0.22.0.22.0.2
back_button_interceptor^6.0.16.0.26.0.2
cached_network_image^3.2.23.2.33.2.3
collection^1.16.01.16.01.17.0
cross_connectivity^3.0.53.0.53.0.5
device_info_plus^6.0.06.0.08.0.0
encrypt^5.0.15.0.15.0.1
flutterflutter0.0.00.0.0
flutter_cache_manager^3.3.03.3.03.3.0
get^4.6.54.6.54.6.5
hive^2.2.32.2.32.2.3
hive_flutter^1.1.01.1.01.1.0
intl^0.17.00.17.00.17.0
liquid_progress_indicator^0.4.00.4.00.4.0
lottie^1.4.31.4.32.0.0
pedantic^1.11.11.11.11.11.1
permission_handler^10.2.010.2.010.2.0
shared_preferences^2.0.152.0.152.0.15
simple_logger^1.9.0+11.9.0+11.9.0+1
superellipse_shape^0.2.00.2.00.2.0
tuple^2.0.12.0.12.0.1
url_launcher^6.1.66.1.76.1.7
Transitive dependencies
PackageConstraintCompatibleLatest
archive-3.3.53.3.5
args-2.3.12.3.1
asn1lib-1.4.01.4.0
async-2.10.02.10.0
cached_network_image_platform_interface-2.0.02.0.0
cached_network_image_web-1.0.21.0.2
characters-1.2.11.2.1
clock-1.1.11.1.1
connectivity_plus-2.3.93.0.2
connectivity_plus_linux-1.3.11.3.1
connectivity_plus_macos-1.2.61.2.6
connectivity_plus_platform_interface-1.2.31.2.3
connectivity_plus_web-1.2.51.2.5
connectivity_plus_windows-1.2.21.2.2
convert-3.1.13.1.1
crypto-3.0.23.0.2
dbus-0.7.80.7.8
device_info_plus_linux-5.0.05.0.0
device_info_plus_macos-5.0.05.0.0
device_info_plus_platform_interface-5.0.07.0.0
device_info_plus_web-5.0.05.0.0
device_info_plus_windows-6.0.06.0.0
ffi-2.0.12.0.1
file-6.1.46.1.4
flutter_blurhash-0.7.00.7.0
flutter_web_plugins-0.0.00.0.0
http-0.13.50.13.5
http_parser-4.0.24.0.2
js-0.6.40.6.5
logging-1.1.01.1.0
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
nm-0.5.00.5.0
octo_image-1.0.21.0.2
path-1.8.21.8.2
path_provider-2.0.112.0.11
path_provider_android-2.0.222.0.22
path_provider_ios-2.0.112.0.11
path_provider_linux-2.1.72.1.7
path_provider_macos-2.0.62.0.6
path_provider_platform_interface-2.0.52.0.5
path_provider_windows-2.1.32.1.3
permission_handler_android-10.2.010.2.0
permission_handler_apple-9.0.79.0.7
permission_handler_platform_interface-3.9.03.9.0
permission_handler_windows-0.1.20.1.2
petitparser-5.1.05.1.0
platform-3.1.03.1.0
plugin_platform_interface-2.1.32.1.3
pointycastle-3.6.23.6.2
process-4.2.44.2.4
rxdart-0.27.70.27.7
shared_preferences_android-2.0.142.0.14
shared_preferences_ios-2.1.12.1.1
shared_preferences_linux-2.1.12.1.1
shared_preferences_macos-2.0.42.0.4
shared_preferences_platform_interface-2.1.02.1.0
shared_preferences_web-2.0.42.0.4
shared_preferences_windows-2.1.12.1.1
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
sqflite-2.2.0+32.2.0+3
sqflite_common-2.4.0+22.4.0+2
stack_trace-1.11.01.11.0
string_scanner-1.2.01.2.0
synchronized-3.0.0+33.0.0+3
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
url_launcher_android-6.0.226.0.22
url_launcher_ios-6.0.176.0.17
url_launcher_linux-3.0.13.0.1
url_launcher_macos-3.0.13.0.1
url_launcher_platform_interface-2.1.12.1.1
url_launcher_web-2.0.132.0.13
url_launcher_windows-3.0.13.0.1
uuid-3.0.73.0.7
vector_math-2.1.22.1.4
win32-3.1.23.1.2
xdg_directories-0.2.0+20.2.0+2
xml-6.1.06.2.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint ^6.0.0 on device_info_plus does not support the stable version 7.0.0.

Try running dart pub upgrade --major-versions device_info_plus to update the constraint.

The constraint ^1.4.3 on lottie does not support the stable version 2.0.0, that was published 16 days ago.

When lottie is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions lottie to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.21, Flutter 3.3.9, Dart 2.18.5.