lints 2.0.0 icon indicating copy to clipboard operation
lints: ^2.0.0 copied to clipboard

Official Dart lint rules. Defines the 'core' and 'recommended' set of lints suggested by the Dart team.

Stable versions of lints

VersionMin Dart SDKUploadedDocumentationArchive
2.0.0Null safety2.17(dev)6 months agoGo to the documentation of lints 2.0.0Download lints 2.0.0 archive
1.0.1Null safety2.1216 months agoGo to the documentation of lints 1.0.1Download lints 1.0.1 archive
1.0.0Null safety2.1216 months agoGo to the documentation of lints 1.0.0Download lints 1.0.0 archive
0.1.0Null safety2.1217 months agoGo to the documentation of lints 0.1.0Download lints 0.1.0 archive

Prerelease versions of lints

VersionMin Dart SDKUploadedDocumentationArchive
1.0.0-dev.0Null safety2.1217 months agoGo to the documentation of lints 1.0.0-dev.0Download lints 1.0.0-dev.0 archive
153
likes
140
pub points
99%
popularity

Publisher

verified publisher icontools.dart.dev

Official Dart lint rules. Defines the 'core' and 'recommended' set of lints suggested by the Dart team.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

More

Packages that depend on lints