lints 2.0.0 icon indicating copy to clipboard operation
lints: ^2.0.0 copied to clipboard

Official Dart lint rules. Defines the 'core' and 'recommended' set of lints suggested by the Dart team.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add lints --dev

With Flutter:

 $ flutter pub add lints --dev

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dev_dependencies:
  lints: ^2.0.0

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

153
likes
140
pub points
99%
popularity

Publisher

verified publisher icontools.dart.dev

Official Dart lint rules. Defines the 'core' and 'recommended' set of lints suggested by the Dart team.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

More

Packages that depend on lints