json_annotation 4.0.0-nullsafety.0
json_annotation: ^4.0.0-nullsafety.0 copied to clipboard

Classes and helper functions that support JSON code generation via the `json_serializable` package.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add json_annotation

With Flutter:

 $ flutter pub pub add json_annotation

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):


dependencies:
  json_annotation: ^4.0.0-nullsafety.0

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:json_annotation/json_annotation.dart';
221
likes
120
pub points
99%
popularity

Publisher

google.dev

Classes and helper functions that support JSON code generation via the `json_serializable` package.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

More

Packages that depend on json_annotation