interzone 1.0.24 icon indicating copy to clipboard operation
interzone: ^1.0.24 copied to clipboard

Interzone is the dart API to talk with moderator, a tiny ephemeral forum

0
likes
70/ 140
pub points
0%
popularity

We analyzed this package 10 hours ago, and awarded it 70 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
10 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://moderator.rocks was unreachable. Make sure that the website is reachable via HEAD requests.

Repository URL doesn't exist.

At the time of the analysis https://github.com/hoodownr/moderatorAPI was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 7 out of 1123 API elements (0.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
0 / 30icon to trigger folding of the section

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 191 issues. Showing the first 2:

ERROR: Target of URI doesn't exist: 'moderator/moderatorCapsuleEntry.dart'.

lib/interzone.dart:4:8

  ╷
4 │ export 'moderator/moderatorCapsuleEntry.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/interzone.dart

WARNING: The '!' will have no effect because the receiver can't be null.

lib/ModeratorSites.dart:150:20

    ╷
150 │     if (_sites[site!.siteName] != null) {
    │                    ^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/ModeratorSites.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bit_array^2.2.02.2.02.2.0
bitcount^0.3.00.3.00.3.0
blurhash_dart^1.1.01.1.01.2.0
crypto^3.0.13.0.23.0.2
fixnum^1.0.01.0.11.0.1
hex^0.2.00.2.00.2.0
hive^2.0.52.2.32.2.3
http^0.13.40.13.50.13.5
image^3.1.03.3.04.0.12
image_compression^1.0.31.0.31.0.3
linkify^4.0.04.1.04.1.0
meta^1.7.01.8.01.8.0
mime^1.0.11.0.41.0.4
ordered_set^5.0.05.0.05.0.0
palette^1.1.0+11.1.0+11.1.0+1
process_run^0.12.2+10.12.5+20.12.5+2
typed_messages^1.1.01.2.11.2.1
Transitive dependencies
PackageConstraintCompatibleLatest
archive-3.3.63.3.6
args-2.3.22.3.2
async-2.10.02.10.0
charcode-1.3.11.3.1
collection-1.17.11.17.1
color_models-1.3.31.3.3
convert-3.1.13.1.1
http_parser-4.0.24.0.2
js-0.6.70.6.7
list_utilities-1.0.31.0.3
num_utilities-1.0.51.0.5
path-1.8.31.8.3
petitparser-5.1.05.1.0
pointycastle-3.6.23.6.2
powers-1.0.0+21.0.0+2
pub_semver-2.1.32.1.3
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
synchronized-3.0.13.0.1
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
unique_list-1.0.11.0.1
xml-6.2.26.2.2
yaml-3.1.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.1.0` on image does not support the stable version `4.0.0`, that was published 28 days ago.

When image is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions image to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Dart 2.19.0.

0
likes
70
pub points
0%
popularity

Publisher

unverified uploader

Interzone is the dart API to talk with moderator, a tiny ephemeral forum

Documentation

API reference

License

Icon for licenses.unknown (LICENSE)

Dependencies

bit_array, bitcount, blurhash_dart, crypto, fixnum, hex, hive, http, image, image_compression, linkify, meta, mime, ordered_set, palette, process_run, typed_messages

More

Packages that depend on interzone