in_app_purchase 3.0.6 icon indicating copy to clipboard operation
in_app_purchase: ^3.0.6 copied to clipboard

A Flutter plugin for in-app purchases. Exposes APIs for making in-app purchases through the App Store and Google Play.

1175
likes
130/ 130
pub points
99%
popularity

We analyzed this package 2 days ago, and awarded it 130 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 10 out of 11 API elements (90.9 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:in_app_purchase/in_app_purchase.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:in_app_purchase/in_app_purchase.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:in_app_purchase/in_app_purchase.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:in_app_purchase/in_app_purchase.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:in_app_purchase/in_app_purchase.dart that imports:
  • package:in_app_purchase_storekit/in_app_purchase_storekit.dart that declares support for platforms: iOS.
Package does not support platform `iOS`.

Because:

  • package:in_app_purchase/in_app_purchase.dart that imports:
  • package:in_app_purchase_android/in_app_purchase_android.dart that declares support for platforms: Android.
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
in_app_purchase_android^0.2.10.2.3+20.2.3+2
in_app_purchase_platform_interface^1.0.01.3.11.3.1
in_app_purchase_storekit^0.3.0+10.3.10.3.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.01.2.1
collection-1.16.01.16.0
json_annotation-4.6.04.6.0
material_color_utilities-0.1.40.2.0
meta-1.7.01.8.0
plugin_platform_interface-2.1.22.1.2
sky_engine-0.0.990.0.99
vector_math-2.1.22.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.14, Flutter 3.0.4, Dart 2.17.5.

1175
likes
130
pub points
99%
popularity

Publisher

verified publisher iconflutter.dev

A Flutter plugin for in-app purchases. Exposes APIs for making in-app purchases through the App Store and Google Play.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

flutter, in_app_purchase_android, in_app_purchase_platform_interface, in_app_purchase_storekit

More

Packages that depend on in_app_purchase