hybrid 0.0.5
hybrid: ^0.0.5 copied to clipboard

A hybrid project for android, ios and flutter.

0
likes
60 / 130
pub points
0 %
popularity

We analyzed this package on Jun 11, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://deplay.one was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 39 out of 284 API elements (13.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:hybrid/hybrid.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/entity/property.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/util/base64.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dio^3.0.73.0.104.0.0
dva_dart^0.1.10.1.20.1.2
dva_flutter^0.1.10.1.20.1.2
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
http_parser-3.1.44.0.0
meta-1.3.01.4.0
path-1.8.01.8.0
rxdart-0.24.10.27.1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.0.7` on dio does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions dio to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.17.1, Flutter 2.2.1, Dart 2.13.1.

0
likes
60
pub points
0%
popularity

Publisher

Unknown

A hybrid project for android, ios and flutter.

Homepage

Documentation

API reference

License

LICENSE

Dependencies

dio, dva_dart, dva_flutter, flutter

More

Packages that depend on hybrid