http_auth 0.3.1
http_auth: ^0.3.1 copied to clipboard

Dart native js
Flutter Android iOS Linux macOS web Windows

Dart http middleware for HTTP Basic and Digest authentication

16
likes
110 / 110
pub points
96 %
popularity

We analyzed this package on Feb 26, 2021, and awarded it 110 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/http_auth_example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 13 out of 14 API elements (92.9 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
convert>=2.1.0 <2.2.02.1.13.0.0
crypto>=2.0.0 <2.2.02.1.53.0.0
http>=0.9.0 <1.0.00.12.20.13.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.2.0
collection-1.14.131.15.0
http_parser-3.1.44.0.0
meta-1.2.41.3.0
path-1.7.01.8.0
source_span-1.7.01.8.1
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.2.01.3.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=2.1.0 <2.2.0` on convert does not support the stable version `3.0.0`, that was published 20 days ago.

When convert is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions convert to update the constraint.

The constraint `>=2.0.0 <2.2.0` on crypto does not support the stable version `3.0.0`, that was published 23 days ago.

When crypto is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions crypto to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Dart 2.10.5.

16
likes
110
pub points
96%
popularity

Dart http middleware for HTTP Basic and Digest authentication

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

marcoesposito1988@gmail.com

License

BSD (LICENSE)

Dependencies

convert, crypto, http

More

Packages that depend on http_auth