http 0.13.1
http: ^0.13.1 copied to clipboard

A composable, multi-platform, Future-based API for HTTP requests.

2419
likes
130 / 130
pub points
100 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 130 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 106 out of 134 API elements (79.1 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
http_parser^4.0.04.0.04.0.0
meta^1.3.01.3.01.3.0
path^1.8.01.8.01.8.0
pedantic^1.10.01.11.01.11.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.2.01.2.0
collection-1.15.01.15.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.15.4, Dart 2.12.2.

2419
likes
130
pub points
100%
popularity

Publisher

dart.dev

A composable, multi-platform, Future-based API for HTTP requests.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

http_parser, meta, path, pedantic

More

Packages that depend on http