hive_generator 0.7.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 92

Extension for hive please go there for documentation.

0.7.0 #

  • Fixed final fields in constructor
  • Support for typeId parameter

0.6.0 #

  • Support for HiveLists
  • Support for getters & setters
  • Support for inheritance

0.5.2 #

  • Fix bug with Uint8Lists

0.5.1 #

  • Bump Hive version

0.5.0 #

  • Support final members

0.4.0+2 #

  • Support for Lists and Maps in strong mode

0.4.0+1 #

  • Support for enums
  • Sanity checks
  • Bugfixes

0.3.0 #

  • Support for typed lists
  • Bugfixes
  • Breaking: Not compatible to previous adapters

0.2.0 #

  • Improve performance of adapers
  • Cast lists to the correct type

0.1.0+1 #

  • First release

example/README.md

Hive samples #

Go here for samples using Hive.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  hive_generator: ^0.7.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:hive_generator/hive_generator.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
89
Health:
Code health derived from static analysis. [more]
97
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
92
Learn more about scoring.

We analyzed this package on Jan 21, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4

Health issues and suggestions

Document public APIs. (-1 points)

2 out of 2 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/src/class_builder.dart. (-1.99 points)

Analysis of lib/src/class_builder.dart reported 4 hints:

line 78 col 35: 'name' is deprecated and shouldn't be used. Check element, or use getDisplayString().

line 105 col 28: 'name' is deprecated and shouldn't be used. Check element, or use getDisplayString().

line 117 col 29: 'name' is deprecated and shouldn't be used. Check element, or use getDisplayString().

line 117 col 43: 'name' is deprecated and shouldn't be used. Check element, or use getDisplayString().

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (dartx).

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.6.0 <3.0.0
analyzer >=0.36.0 <0.40.0 0.39.4
build ^1.1.6 1.2.2
dartx ^0.2.0 0.2.0 0.3.0
hive >=1.3.0 <2.0.0 1.3.0
source_gen ^0.9.4+4 0.9.4+7
Transitive dependencies
_fe_analyzer_shared 1.0.3
args 1.5.2
async 2.4.0
characters 0.3.1 0.5.0
charcode 1.1.2
collection 1.14.12
convert 2.1.1
crypto 2.1.4
csslib 0.16.1
dart_style 1.3.3
glob 1.2.0
html 0.14.0+3
js 0.6.1+1
logging 0.11.4
matcher 0.12.6
meta 1.1.8
node_interop 1.0.3
node_io 1.0.1+2
package_config 1.1.0
path 1.6.4
pointycastle 1.0.2
pub_semver 1.4.2
quiver 2.0.5 2.1.2+1
source_span 1.6.0
stack_trace 1.9.3
string_scanner 1.0.5
term_glyph 1.1.0
time 1.2.0
typed_data 1.1.6
watcher 0.9.7+13
yaml 2.2.0
Dev dependencies
build_runner any
build_test any
pedantic 1.7.0 1.9.0
test ^1.6.4