hive_flutter 0.3.0+2

  • Readme
  • Changelog
  • Example
  • Installing
  • 98

Extension for hive please go there for documentation. #

0.3.0+2 #

  • Fixed GitHub homepage path

0.3.0+1 #

  • Added box.listenable() which returns a ValueListenable<Box>
  • Added Hive.initFlutter()
  • Breaking Deprecated WatchBoxBuilder in favor of box.listenable(). Will be removed in a future version

0.2.1 #

  • Bump Hive version
  • Changed WatchBoxBuilderState to _WatchBoxBuilderState

0.2.0 #

  • Breaking API change, renamed HiveBuilder to BoxWidgetBuilder.

0.1.0 #

  • First version

example/README.md

Hive samples #

Go here for samples using Hive.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  hive_flutter: ^0.3.0+2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:hive_flutter/hive_flutter.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
97
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
98
Learn more about scoring.

We analyzed this package on Mar 27, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.6.0 <3.0.0
flutter 0.0.0
hive >=1.0.0 <2.0.0 1.4.1+1
path >=1.6.0 <1.7.0 1.6.4
path_provider >=1.0.0 <2.0.0 1.6.5
Transitive dependencies
charcode 1.1.3
collection 1.14.11 1.14.12
convert 2.1.1
crypto 2.1.4
meta 1.1.8
path_provider_macos 0.0.4
path_provider_platform_interface 1.0.1
platform 2.2.1
plugin_platform_interface 1.0.2
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test
pedantic >=1.8.0 <2.0.0