grpc 3.1.0 icon indicating copy to clipboard operation
grpc: ^3.1.0 copied to clipboard

Dart implementation of gRPC, a high performance, open-source universal RPC framework.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add grpc

With Flutter:

 $ flutter pub add grpc

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  grpc: ^3.1.0

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:grpc/grpc.dart';
259
likes
130
pub points
97%
popularity

Publisher

verified publisher icondart.dev

Dart implementation of gRPC, a high performance, open-source universal RPC framework.

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

Icon for licenses.Apache-2.0 (LICENSE)

Dependencies

archive, async, crypto, fixnum, googleapis_auth, http, http2, meta, protobuf

More

Packages that depend on grpc