gcloud 0.8.2
gcloud: ^0.8.2 copied to clipboard

High level idiomatic Dart API for Google Cloud Storage, Pub-Sub and Datastore.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add gcloud

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):


dependencies:
  gcloud: ^0.8.2

Alternatively, your editor might support dart pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:gcloud/common.dart';
import 'package:gcloud/datastore.dart';
import 'package:gcloud/db.dart';
import 'package:gcloud/db/metamodel.dart';
import 'package:gcloud/http.dart';
import 'package:gcloud/pubsub.dart';
import 'package:gcloud/service_scope.dart';
import 'package:gcloud/storage.dart';
30
likes
110
pub points
89%
popularity

Publisher

labs.dart.dev

High level idiomatic Dart API for Google Cloud Storage, Pub-Sub and Datastore.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

_discoveryapis_commons, googleapis, http, meta

More

Packages that depend on gcloud