functional_widget 0.9.0
functional_widget: ^0.9.0 copied to clipboard

A code generator that generates widget classes from their implementation as a function.

70
likes
70 / 130
pub points
81 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/rrousselGit/functional_widget/tree/master/functional_widget was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 6 API elements (50.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:functional_widget/builder.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 8 issues. Showing the first 2:

INFO: The library 'package:build/build.dart' is legacy, and should not be imported into a null safe library.

lib/builder.dart:1:8

  ╷
1 │ import 'package:build/build.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/builder.dart

INFO: The library 'package:source_gen/source_gen.dart' is legacy, and should not be imported into a null safe library.

lib/builder.dart:4:8

  ╷
4 │ import 'package:source_gen/source_gen.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/builder.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run pub outdated: pub get failed:
Because functional_widget depends on code_gen_tester from path which doesn't exist (could not find package code_gen_tester at "../code_gen_tester"), version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Null safety support has one or more issues.

Package is not null safe

Because:

  • functional_widget that depends on:
  • code_builder that doesn't opt in to null safety
For more information

Try running pub outdated --mode=null-safety. Be sure to read the migration guide.

Analysed with Pana 0.15.4, Dart 2.12.2.

70
likes
70
pub points
81%
popularity

Publisher

dash-overflow.net

A code generator that generates widget classes from their implementation as a function.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

analyzer, build, build_config, code_builder, functional_widget_annotation, meta, source_gen

More

Packages that depend on functional_widget