fpdart 0.0.13 icon indicating copy to clipboard operation
fpdart: ^0.0.13 copied to clipboard

Functional programming in Dart and Flutter. All the main functional programming types and patterns fully documented, tested, and with examples.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add fpdart

With Flutter:

 $ flutter pub add fpdart

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  fpdart: ^0.0.13

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:fpdart/fpdart.dart';
145
likes
130
pub points
92%
popularity

Publisher

shield icon for verified publisherssandromaglione.com

Functional programming in Dart and Flutter. All the main functional programming types and patterns fully documented, tested, and with examples.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

More

Packages that depend on fpdart