flutter_request_bloc 0.2.0
flutter_request_bloc: ^0.2.0 copied to clipboard

Package that facilitates REST API calls using flutter_bloc and hydrated_bloc.

1
likes
100/ 130
pub points
76%
popularity

We analyzed this package on Oct 21, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 33 out of 60 API elements (55.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:flutter_request_bloc/flutter_request_bloc.dart that imports:
  • package:flutter_request_bloc/cubits/request_persistant_cubit.dart that imports:
  • package:hydrated_bloc/hydrated_bloc.dart that imports:
  • package:hydrated_bloc/src/hydrated_storage.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
equatable^2.0.02.0.32.0.3
flutterflutter0.0.00.0.0
flutter_bloc^7.0.07.3.17.3.1
hydrated_bloc^7.0.07.1.07.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
bloc-7.2.17.2.1
characters-1.1.01.2.0
collection-1.15.01.15.0
crypto-3.0.13.0.1
hive-2.0.42.0.4
meta-1.7.01.7.0
nested-1.0.01.0.0
provider-6.0.16.0.1
sky_engine-0.0.990.0.99
synchronized-3.0.03.0.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Null safety support has one or more issues.

Unable to access import.

Because:

  • package:flutter_request_bloc/cubits/request_cubit.dart that imports:
  • package:flutter_request_bloc/flutter_request_bloc.dart that imports:
  • package:flutter_request_bloc/cubits/request_persistant_cubit.dart that imports:
  • package:hydrated_bloc/hydrated_bloc.dart that imports:
  • package:hydrated_bloc/src/hydrated_storage.dart that imports:
  • package:hydrated_bloc/src/hydrated_cipher.dart that imports:
  • package:hive/hive.dart that imports:
  • package:hive/src/object/hive_object.dart that imports:
  • package:hive/src/object/hive_list_impl.dart that imports:
  • package:hive/src/hive_impl.dart that imports:
  • package:hive/src/backend/storage_backend.dart that imports:
  • package:hive/src/backend/js/backend_manager.dart that imports:
  • package:hive/src/backend/js/storage_backend_js.dart that imports:
  • dart:indexed_db where dart:indexed_db is inaccessible.
Unable to access import.

Because:

  • package:flutter_request_bloc/cubits/request_persistant_cubit.dart that imports:
  • package:hydrated_bloc/hydrated_bloc.dart that imports:
  • package:hydrated_bloc/src/hydrated_storage.dart that imports:
  • package:hydrated_bloc/src/hydrated_cipher.dart that imports:
  • package:hive/hive.dart that imports:
  • package:hive/src/object/hive_object.dart that imports:
  • package:hive/src/object/hive_list_impl.dart that imports:
  • package:hive/src/hive_impl.dart that imports:
  • package:hive/src/backend/storage_backend.dart that imports:
  • package:hive/src/backend/js/backend_manager.dart that imports:
  • package:hive/src/backend/js/storage_backend_js.dart that imports:
  • dart:indexed_db where dart:indexed_db is inaccessible.
Unable to access import.

Because:

  • package:flutter_request_bloc/flutter_request_bloc.dart that imports:
  • package:flutter_request_bloc/cubits/request_persistant_cubit.dart that imports:
  • package:hydrated_bloc/hydrated_bloc.dart that imports:
  • package:hydrated_bloc/src/hydrated_storage.dart that imports:
  • package:hydrated_bloc/src/hydrated_cipher.dart that imports:
  • package:hive/hive.dart that imports:
  • package:hive/src/object/hive_object.dart that imports:
  • package:hive/src/object/hive_list_impl.dart that imports:
  • package:hive/src/hive_impl.dart that imports:
  • package:hive/src/backend/storage_backend.dart that imports:
  • package:hive/src/backend/js/backend_manager.dart that imports:
  • package:hive/src/backend/js/storage_backend_js.dart that imports:
  • dart:indexed_db where dart:indexed_db is inaccessible.
Unable to access import.

Because:

  • package:flutter_request_bloc/widgets/request_builder.dart that imports:
  • package:flutter_request_bloc/flutter_request_bloc.dart that imports:
  • package:flutter_request_bloc/cubits/request_persistant_cubit.dart that imports:
  • package:hydrated_bloc/hydrated_bloc.dart that imports:
  • package:hydrated_bloc/src/hydrated_storage.dart that imports:
  • package:hydrated_bloc/src/hydrated_cipher.dart that imports:
  • package:hive/hive.dart that imports:
  • package:hive/src/object/hive_object.dart that imports:
  • package:hive/src/object/hive_list_impl.dart that imports:
  • package:hive/src/hive_impl.dart that imports:
  • package:hive/src/backend/storage_backend.dart that imports:
  • package:hive/src/backend/js/backend_manager.dart that imports:
  • package:hive/src/backend/js/storage_backend_js.dart that imports:
  • dart:indexed_db where dart:indexed_db is inaccessible.
For more information

Try running dart pub outdated --mode=null-safety. Be sure to read the migration guide.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

1
likes
100
pub points
76%
popularity

Package that facilitates REST API calls using flutter_bloc and hydrated_bloc.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

GPL-3.0 (LICENSE)

Dependencies

equatable, flutter, flutter_bloc, hydrated_bloc

More

Packages that depend on flutter_request_bloc