flutter_html_textview 0.2.6 icon indicating copy to clipboard operation
flutter_html_textview: ^0.2.6 copied to clipboard

Flutter Plugin to render html in textview

4
likes
70/ 140
pub points
57%
popularity

We analyzed this package 31 hours ago, and awarded it 70 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
10 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 17 API elements (11.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform Windows.

Because:

  • package:flutter_html_textview/flutter_html_textview.dart that imports:
  • package:flutter_html_textview/html_parser.dart that imports:
  • package:cached_network_image/cached_network_image.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/cache_object.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS.

Package does not support platform Linux.

Because:

  • package:flutter_html_textview/flutter_html_textview.dart that imports:
  • package:flutter_html_textview/html_parser.dart that imports:
  • package:cached_network_image/cached_network_image.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/cache_object.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS.

Package does not support platform macOS.

Because:

  • package:flutter_html_textview/flutter_html_textview.dart that imports:
  • package:flutter_html_textview/html_parser.dart that imports:
  • package:cached_network_image/cached_network_image.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/cache_object.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS.

Package does not support platform Web.

Because:

  • package:flutter_html_textview/flutter_html_textview.dart that imports:
  • package:flutter_html_textview/html_parser.dart that imports:
  • package:cached_network_image/cached_network_image.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/cache_object.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

INFO: Name non-constant identifiers using lowerCamelCase.

lib/html_parser.dart:12:16

   ╷
12 │   List<Widget> HParse(String html) {
   │                ^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/html_parser.dart

INFO: 'List.List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/html_parser.dart:14:35

   ╷
14 │     List<Widget> widgetList = new List();
   │                                   ^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/html_parser.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cached_network_image^0.4.00.4.23.2.3
flutterflutter0.0.00.0.0
html^0.13.30.13.4+20.15.1
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.10.02.10.0
characters-1.2.11.2.1
charcode-1.3.11.3.1
collection-1.16.01.17.0
convert-2.1.13.1.1
crypto-2.1.53.0.2
csslib-0.15.00.17.2
flutter_cache_manager-0.1.23.3.0
http-0.11.3+170.13.5
http_parser-3.1.44.0.2
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
path-1.8.31.8.3
path_provider-0.4.12.0.11
shared_preferences-0.4.32.0.15
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
synchronized-1.5.3+23.0.0+3
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
utf-0.9.0+50.9.0+5
uuid-1.0.33.0.7
vector_math-2.1.22.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint ^0.4.0 on cached_network_image does not support the stable version 0.5.0.

Try running dart pub upgrade --major-versions cached_network_image to update the constraint.

The constraint ^0.13.3 on html does not support the stable version 0.14.0.

Try running dart pub upgrade --major-versions html to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint >=2.0.0-dev.28.0 <3.0.0) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.21, Flutter 3.3.9, Dart 2.18.5.