large Flutter Favorite logosmall Flutter Favorite logo

flutter_bloc 7.0.0-nullsafety.3 icon indicating copy to clipboard operation
flutter_bloc: ^7.0.0-nullsafety.3 copied to clipboard

Flutter Widgets that make it easy to implement the BLoC (Business Logic Component) design pattern. Built to be used with the bloc state management package.

5065
likes
110/ 130
pub points
100%
popularity

We analyzed this package 5 days ago, and awarded it 110 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
10 / 10icon to trigger folding of the section

10/10 points: Package has an example

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 8 issues. Showing the first 2:

INFO: The import of 'package:bloc/bloc.dart' is unnecessary because all of the used elements are also provided by the import of 'package:flutter_bloc/flutter_bloc.dart'.

lib/src/bloc_builder.dart:1:8

  ╷
1 │ import 'package:bloc/bloc.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/bloc_builder.dart

INFO: The import of 'package:provider/provider.dart' is unnecessary because all of the used elements are also provided by the import of 'package:flutter_bloc/flutter_bloc.dart'.

lib/src/bloc_builder.dart:4:8

  ╷
4 │ import 'package:provider/provider.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/bloc_builder.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bloc>=7.0.0-nullsafety.3 <7.0.07.0.0-nullsafety.48.1.0
flutterflutter0.0.00.0.0
provider>=5.0.0-nullsafety.5 <5.0.05.0.0-nullsafety.56.0.5
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
collection-1.17.01.17.1
js-0.6.50.6.7
material_color_utilities-0.2.00.2.0
meta-1.8.01.9.0
nested-1.0.01.0.0
sky_engine-0.0.990.0.99
vector_math-2.1.42.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=7.0.0-nullsafety.3 <7.0.0` on bloc does not support the stable version `7.0.0`.

Try running dart pub upgrade --major-versions bloc to update the constraint.

The constraint `>=5.0.0-nullsafety.5 <5.0.0` on provider does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions provider to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.

5065
likes
110
pub points
100%
popularity

Publisher

verified publisher iconbloclibrary.dev

Flutter Widgets that make it easy to implement the BLoC (Business Logic Component) design pattern. Built to be used with the bloc state management package.

Homepage
Repository (GitHub)
View/report issues

Documentation

Documentation

License

Icon for licenses.MIT (LICENSE)

Dependencies

bloc, flutter, provider

More

Packages that depend on flutter_bloc