flutter_appcenter 1.0.11
flutter_appcenter: ^1.0.11 copied to clipboard

Flutter Android iOS

Support Android/iOS to Build, Test, and Distribute, Analytics and Diagnostics services.

3
likes
75 / 110
pub points
61 %
popularity

We analyzed this package on Mar 2, 2021, and awarded it 75 pub points (of a possible 110):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: Failed to run dartdoc

  • Running dartdoc failed with the following output:
Exceeded timeout of 0:20:00.000000
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_appcenter/flutter_appcenter.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

INFO: Unused import: 'package:flutter/foundation.dart'.

lib/flutter_appcenter.dart:7:8

  ╷
7 │ import 'package:flutter/foundation.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/flutter_appcenter.dart

lib/comment/check_permission.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
android_metadata^0.1.20.1.30.1.3
dio^3.0.93.0.103.0.10
flutterflutter0.0.00.0.0
install_plugin^2.0.12.0.12.0.1
open_appstore^1.0.21.0.21.0.2
package_info^0.4.10.4.3+42.0.0
path_provider^1.6.111.6.272.0.1
permission_handler^5.0.1+15.1.0+25.1.0+2
progress_dialog^1.2.41.2.41.2.4
url_launcher^5.4.115.7.106.0.2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
charcode-1.1.31.2.0
collection-1.15.0-nullsafety.31.15.0
ffi-0.1.31.0.0
file-5.2.16.1.0
flutter_web_plugins-0.0.00.0.0
http_parser-3.1.44.0.0
intl-0.16.10.17.0
meta-1.3.0-nullsafety.31.3.0
path-1.7.01.8.0
path_provider_linux-0.0.1+22.0.0
path_provider_macos-0.0.4+82.0.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.4+32.0.0
permission_handler_platform_interface-2.0.23.0.0+1
platform-2.2.13.0.0
plugin_platform_interface-1.0.32.0.0
process-3.0.134.1.0
sky_engine-0.0.990.0.99
source_span-1.7.01.8.1
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.3.0-nullsafety.31.3.0
url_launcher_linux-0.0.1+42.0.0
url_launcher_macos-0.0.1+92.0.0
url_launcher_platform_interface-1.0.92.0.2
url_launcher_web-0.1.5+32.0.0
url_launcher_windows-0.0.1+32.0.0
vector_math-2.1.0-nullsafety.32.1.0
win32-1.7.4+12.0.0
xdg_directories-0.1.20.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.4.1` on package_info does not support the stable version `2.0.0`, that was published 11 days ago.

When package_info is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions package_info to update the constraint.

The constraint `^1.6.11` on path_provider does not support the stable version `2.0.0`, that was published 8 days ago.

When path_provider is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions path_provider to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Flutter 1.22.6, Dart 2.10.5.