firestore_search 0.1.9 icon indicating copy to clipboard operation
firestore_search: ^0.1.9 copied to clipboard

This package helps developers to implement cloud_firestore search in their apps.

80
likes
120/ 140
pub points
89%
popularity

We analyzed this package 20 hours ago, and awarded it 120 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 15 out of 44 API elements (34.1 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 4 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ MacOS
  • ✓ Web

These platforms are not supported:

Package does not support platform Windows.

Because:

  • package:firestore_search/firestore_search.dart that imports:
  • package:firestore_search/src/mvc/views/search_results.dart that imports:
  • package:firestore_search/src/mvc/services/firestore_service.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: Android, iOS, macOS, Web.

Package does not support platform Linux.

Because:

  • package:firestore_search/firestore_search.dart that imports:
  • package:firestore_search/src/mvc/views/search_results.dart that imports:
  • package:firestore_search/src/mvc/services/firestore_service.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: Android, iOS, macOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:firestore_search/firestore_search.dart that imports:
  • package:firestore_search/src/mvc/views/search_results.dart that imports:
  • package:firestore_search/src/mvc/services/firestore_service.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that imports:
  • package:firebase_core_platform_interface/firebase_core_platform_interface.dart that imports:
  • package:firebase_core_platform_interface/src/pigeon/test_api.dart that imports:
  • package:flutter_test/flutter_test.dart that imports:
  • package:flutter_test/src/widget_tester.dart that imports:
  • package:flutter_test/src/test_text_input.dart that imports:
  • package:flutter_test/src/deprecated.dart that imports:
  • package:flutter_test/src/binding.dart that imports:
  • package:flutter_test/src/platform.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

INFO: Unused import: 'package:firestore_search/src/mvc/controllers/firestore_search_controller.dart'.

lib/firestore_search.dart:2:8

  ╷
2 │ import 'package:firestore_search/src/mvc/controllers/firestore_search_controller.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/firestore_search.dart

INFO: The import of 'package:flutter/cupertino.dart' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/material.dart'.

lib/firestore_search.dart:5:8

  ╷
5 │ import 'package:flutter/cupertino.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/firestore_search.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cloud_firestore^3.1.43.5.14.1.0
flutterflutter0.0.00.0.0
get^4.3.84.6.54.6.5
Transitive dependencies
PackageConstraintCompatibleLatest
_flutterfire_internals-1.0.21.0.9
async-2.9.02.10.0
boolean_selector-2.1.02.1.1
characters-1.2.11.2.1
clock-1.1.11.1.1
cloud_firestore_platform_interface-5.7.75.9.0
cloud_firestore_web-2.8.103.1.0
collection-1.16.01.17.0
fake_async-1.3.11.3.1
firebase_core-1.24.02.3.0
firebase_core_platform_interface-4.5.24.5.2
firebase_core_web-1.7.32.0.1
flutter_test-0.0.00.0.0
flutter_web_plugins-0.0.00.0.0
js-0.6.40.6.5
matcher-0.12.120.12.13
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
path-1.8.21.8.3
plugin_platform_interface-2.1.32.1.3
sky_engine-0.0.990.0.99
source_span-1.9.01.9.1
stack_trace-1.10.01.11.0
stream_channel-2.1.02.1.1
string_scanner-1.1.11.2.0
term_glyph-1.2.11.2.1
test_api-0.4.120.4.16
vector_math-2.1.22.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint ^3.1.4 on cloud_firestore does not support the stable version 4.0.0.

Try running dart pub upgrade --major-versions cloud_firestore to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.21, Flutter 3.3.9, Dart 2.18.5.

80
likes
120
pub points
89%
popularity

Publisher

verified publisher iconasadhameed.com

This package helps developers to implement cloud_firestore search in their apps.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

cloud_firestore, flutter, get

More

Packages that depend on firestore_search