ext_video_player 0.1.2 icon indicating copy to clipboard operation
ext_video_player: ^0.1.2 copied to clipboard

Flutter plugin for displaying inline with other Flutter widgets on Android and iOS. This plugin also supports playing youtube videos & RTMP Streams

74
likes
100/ 140
pub points
87%
popularity

We analyzed this package 1 hour ago, and awarded it 100 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 72 out of 75 API elements (96.0 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform Windows.

Because:

  • package:ext_video_player/ext_video_player.dart that declares support for platforms: Android, iOS, Web.

Package does not support platform Linux.

Because:

  • package:ext_video_player/ext_video_player.dart that declares support for platforms: Android, iOS, Web.

Package does not support platform macOS.

Because:

  • package:ext_video_player/ext_video_player.dart that declares support for platforms: Android, iOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:ext_video_player/ext_video_player.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
10 / 30icon to trigger folding of the section

10/30 points: code has no errors, warnings, lints, or formatting issues

Found 10 issues. Showing the first 2:

WARNING: Missing case clause for 'contentUri'.

lib/ext_video_player.dart:291:5

    ╷
291 │     switch (dataSourceType) {
    │     ^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/ext_video_player.dart

WARNING: The '!' will have no effect because the receiver can't be null.

lib/ext_video_player.dart:613:28

    ╷
613 │     WidgetsBinding.instance!.addObserver(this);
    │                            ^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/ext_video_player.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
http^0.13.40.13.50.13.5
meta^1.0.51.8.01.8.0
video_player_platform_interface^4.1.04.2.06.0.0
video_player_web^2.0.22.0.122.0.12
youtube_explode_dart^1.10.101.12.31.12.3
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.9.02.10.0
boolean_selector-2.1.02.1.1
characters-1.2.11.2.1
clock-1.1.11.1.1
collection-1.16.01.17.0
csslib-0.17.20.17.2
fake_async-1.3.11.3.1
flutter_test-0.0.00.0.0
flutter_web_plugins-0.0.00.0.0
freezed_annotation-2.2.02.2.0
html-0.15.10.15.1
http_parser-4.0.24.0.2
js-0.6.40.6.5
json_annotation-4.7.04.7.0
matcher-0.12.120.12.13
material_color_utilities-0.1.50.2.0
path-1.8.21.8.3
petitparser-5.1.05.1.0
sky_engine-0.0.990.0.99
source_span-1.9.01.9.1
stack_trace-1.10.01.11.0
stream_channel-2.1.02.1.1
string_scanner-1.1.11.2.0
term_glyph-1.2.11.2.1
test_api-0.4.120.4.16
typed_data-1.3.11.3.1
vector_math-2.1.22.1.4
xml-6.1.06.2.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint ^4.1.0 on video_player_platform_interface does not support the stable version 5.0.0.

Try running dart pub upgrade --major-versions video_player_platform_interface to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.21, Flutter 3.3.9, Dart 2.18.5.

74
likes
100
pub points
87%
popularity

Publisher

verified publisher iconkarthikponnam.dev

Flutter plugin for displaying inline with other Flutter widgets on Android and iOS. This plugin also supports playing youtube videos & RTMP Streams

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

flutter, http, meta, video_player_platform_interface, video_player_web, youtube_explode_dart

More

Packages that depend on ext_video_player