essentials 0.0.1 icon indicating copy to clipboard operation
essentials: ^0.0.1 copied to clipboard

Essential cross platform APIs for your Flutter apps

3
likes
70/ 140
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 70 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 11 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:essentials/essentials.dart that imports:
  • package:contacts_plugin/contacts_plugin.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:essentials/essentials.dart that imports:
  • package:contacts_plugin/contacts_plugin.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:essentials/essentials.dart that imports:
  • package:contacts_plugin/contacts_plugin.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:essentials/essentials.dart that imports:
  • package:contacts_plugin/contacts_plugin.dart that declares support for platforms: Android, iOS.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: Unused import: 'dart:async'.

lib/essentials.dart:3:8

  ╷
3 │ import 'dart:async';
  │        ^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/essentials.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
contacts_plugin^0.0.10.0.30.0.3
flutterflutter0.0.00.0.0
geolocator>=1.6.4 <2.0.01.7.09.0.2
google_api_availability^1.0.21.0.6+13.0.1
permission_handler>=2.0.0 <3.0.02.2.010.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
collection-1.16.01.16.0
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
sky_engine-0.0.990.0.99
vector_math-2.1.22.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `>=1.6.4 <2.0.0` on geolocator does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions geolocator to update the constraint.

The constraint `^1.0.2` on google_api_availability does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions google_api_availability to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0-dev.68.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.17, Flutter 3.3.2, Dart 2.18.1.

3
likes
70
pub points
0%
popularity

Publisher

verified publisher iconbaseflow.com

Essential cross platform APIs for your Flutter apps

Homepage

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

contacts_plugin, flutter, geolocator, google_api_availability, permission_handler

More

Packages that depend on essentials