dwds 9.1.0
dwds: ^9.1.0 copied to clipboard

A service that proxies between the Chrome debug protocol and the Dart VM service protocol.

9
likes
80 / 130
pub points
97 %
popularity

We analyzed this package on Apr 14, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 164 out of 364 API elements (45.1 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:dwds/dwds.dart that imports:
  • package:dwds/src/services/expression_compiler_service.dart that imports:
  • package:dwds/src/utilities/dart_uri.dart that imports:
  • package:package_config/package_config.dart that imports:
  • package:package_config/src/package_config_io.dart that imports:
  • package:package_config/src/util_io.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run pub outdated: pub get failed:
Because dwds depends on frontend_server_common from path which doesn't exist (could not find package frontend_server_common at "../frontend_server_common"), version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Null safety support has one or more issues.

Package is not null safe

Because:

  • dwds that depends on:
  • webkit_inspection_protocol that doesn't opt in to null safety
For more information

Try running pub outdated --mode=null-safety. Be sure to read the migration guide.

Analysed with Pana 0.15.4, Dart 2.12.2.