dva_dart 0.1.2

Dart native js
Flutter Android iOS web

State manager for dart and flutter, using idea from dva.js and combined with rxdart, a simpler way to manage your app's state.

1
likes
100 / 110
pub points
13 %
popularity

We analyzed this package on Sep 18, 2020, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 110 API elements (1.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
meta^1.1.61.2.31.2.3
rxdart>=0.23.1 <0.25.00.24.10.24.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

1
likes
100
pub points
13%
popularity

State manager for dart and flutter, using idea from dva.js and combined with rxdart, a simpler way to manage your app's state.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

ghostcorn@gmail.com

License

MIT (LICENSE)

Dependencies

meta, rxdart

More

Packages that depend on dva_dart