dart_console 1.1.2 icon indicating copy to clipboard operation
dart_console: ^1.1.2 copied to clipboard

A helper library for command-line applications that need more control over input/output than the standard library provides.

89
likes
130/ 140
pub points
86%
popularity

We analyzed this package 3 hours ago, and awarded it 130 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 74 out of 222 API elements (33.3 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package does not support platform Android.

Because:

  • package:dart_console/dart_console.dart that declares support for platforms: Windows, Linux, macOS.

Package does not support platform iOS.

Because:

  • package:dart_console/dart_console.dart that declares support for platforms: Windows, Linux, macOS.

Package does not support platform Web.

Because:

  • package:dart_console/dart_console.dart that declares support for platforms: Windows, Linux, macOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform Linux.

Because:

  • package:dart_console/dart_console.dart that imports:
  • package:dart_console/src/console.dart that imports:
  • package:dart_console/src/ffi/win/termlib_win.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.

Package does not support platform macOS.

Because:

  • package:dart_console/dart_console.dart that imports:
  • package:dart_console/src/console.dart that imports:
  • package:dart_console/src/ffi/win/termlib_win.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
characters^1.2.11.2.11.2.1
ffi>=1.0.0 <3.0.02.0.12.0.1
intl^0.17.00.17.00.17.0
win32^2.6.12.7.03.1.2
Transitive dependencies
PackageConstraintCompatibleLatest
clock-1.1.11.1.1
path-1.8.31.8.3

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint ^2.6.1 on win32 does not support the stable version 3.0.0.

Try running dart pub upgrade --major-versions win32 to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.21, Dart 2.18.4.

89
likes
130
pub points
86%
popularity

Publisher

verified publisher iconsneath.org

A helper library for command-line applications that need more control over input/output than the standard library provides.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

characters, ffi, intl, win32

More

Packages that depend on dart_console