large Flutter Favorite logosmall Flutter Favorite logo

dart_code_metrics 4.16.0 icon indicating copy to clipboard operation
dart_code_metrics: ^4.16.0 copied to clipboard

Software analytics tool that helps developers analyse and improve software quality.

555
likes
130/ 130
pub points
99%
popularity

We analyzed this package 10 hours ago, and awarded it 130 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 126 out of 222 API elements (56.8 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:dart_code_metrics/analyzer_plugin.dart that imports:
  • package:dart_code_metrics/src/analyzer_plugin/analyzer_plugin_starter.dart that imports:
  • package:dart_code_metrics/src/analyzer_plugin/analyzer_plugin.dart that imports:
  • package:dart_code_metrics/src/analyzer_plugin/analyzer_plugin_utils.dart that imports:
  • package:dart_code_metrics/src/utils/path_utils.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer>=2.4.0 <4.2.04.1.04.2.0
analyzer_plugin>=0.8.0 <0.11.00.10.00.11.0
ansicolor^2.0.12.0.12.0.1
args^2.0.02.3.12.3.1
collection^1.15.01.16.01.16.0
crypto^3.0.03.0.23.0.2
file^6.0.06.1.26.1.2
glob^2.0.12.1.02.1.0
html>=0.15.0 <1.0.00.15.00.15.0
meta^1.3.01.8.01.8.0
path^1.8.01.8.21.8.2
source_span^1.8.01.9.01.9.0
xml>=5.3.0 <7.0.06.1.06.1.0
yaml^3.1.03.1.13.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-40.0.041.0.0
async-2.9.02.9.0
convert-3.0.23.0.2
csslib-0.17.20.17.2
dart_style-2.2.32.2.3
package_config-2.1.02.1.0
petitparser-5.0.05.0.0
pub_semver-2.1.12.1.1
string_scanner-1.1.11.1.1
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
watcher-1.0.11.0.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=2.4.0 <4.2.0` on analyzer does not support the stable version `4.2.0`, that was published 0 days ago.

When analyzer is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `>=0.8.0 <0.11.0` on analyzer_plugin does not support the stable version `0.11.0`, that was published 8 days ago.

When analyzer_plugin is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions analyzer_plugin to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.13, Dart 2.17.5.