dart_chromecast 0.2.5
dart_chromecast: ^0.2.5 copied to clipboard

Cast videos to your ChromeCast device using Dart

27
likes
60 / 130
pub points
81 %
popularity

We analyzed this package on Jun 9, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 22 out of 291 API elements (7.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:dart_chromecast/casting/cast.dart that imports:
  • package:dart_chromecast/casting/cast_device.dart that imports:
  • package:http/io_client.dart that imports:
  • package:http/src/io_streamed_response.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 12 issues. Showing the first 2:

lib/casting/cast.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/casting/cast_media.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^2.0.02.1.12.1.1
cli_util^0.3.00.3.00.3.0
http^0.13.10.13.30.13.3
logging^1.0.11.0.11.0.1
multicast_dns^0.3.00.3.00.3.0
protobuf^2.0.02.0.02.0.0
protoc_plugin^20.0.020.0.020.0.0
xml^5.1.05.1.25.1.2
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-22.0.022.0.0
analyzer-1.7.01.7.1
async-2.7.02.7.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
convert-3.0.03.0.0
crypto-3.0.13.0.1
dart_style-1.3.142.0.1
file-6.1.16.1.1
fixnum-1.0.01.0.0
glob-2.0.12.0.1
http_parser-4.0.04.0.0
meta-1.4.01.4.0
package_config-2.0.02.0.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
petitparser-4.2.04.2.0
pub_semver-2.0.02.0.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-1.0.01.0.0
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Null safety support has one or more issues.

Package is not null safe

Because:

  • dart_chromecast that depends on:
  • protoc_plugin that depends on:
  • dart_style that doesn't opt in to null safety
For more information

Try running dart pub outdated --mode=null-safety. Be sure to read the migration guide.

Analysed with Pana 0.17.1, Dart 2.13.1.

27
likes
60
pub points
81%
popularity

Publisher

Unknown

Cast videos to your ChromeCast device using Dart

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

args, cli_util, http, logging, multicast_dns, protobuf, protoc_plugin, xml

More

Packages that depend on dart_chromecast