cupertino_icons 0.1.3

  • Readme
  • Changelog
  • Installing
  • 90

Cupertino Icons #

This is an asset repo containing the default set of icon assets used by Flutter's Cupertino widgets.

Issues #

For issues, file directly in the main Flutter repo.

Icons #

image map of glyphs

0.1.3 #

  • Updated 'chevron left' and 'chevron right' icons to match San Francisco font

0.1.2 #

  • Fix linter warning for missing lib/ folder.
  • Constrain to Dart 2.

0.1.1 #

  • Initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  cupertino_icons: ^0.1.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

Popularity:
Describes how popular the package is relative to other packages. [more]
100
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
51
Overall:
Weighted score of the above. [more]
90
Learn more about scoring.

We analyzed this package on May 13, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.1
  • pana: 0.13.8-dev

Maintenance issues and suggestions

No valid SDK. (-20 points)

The analysis could not detect a valid SDK that can use this package.

Make sure dartdoc successfully runs on your package's source files. (-10 points)

exitCode: 255 stdout: Documenting cupertino_icons... Initialized dartdoc with 37 libraries in 31.6 seconds Validating docs... no issues found Documented 0 public libraries in 5.6 seconds stderr: Unhandled exception: dartdoc could not find any libraries to document #0 Dartdoc.generateDocs (package:dartdoc/dartdoc.dart:196:7)

The package description is too short. (-19 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0