crypto_keys 0.3.0
crypto_keys: ^0.3.0 copied to clipboard

A library for doing cryptographic signing/verifying and encrypting/decrypting.

14
likes
130/ 130
pub points
93%
popularity

We analyzed this package on Oct 21, 2021, and awarded it 130 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 54 out of 83 API elements (65.1 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.14.131.15.01.15.0
meta^1.3.01.7.01.7.0
pointycastle^3.0.03.3.43.3.4
quiver^3.0.03.0.1+13.0.1+1
Transitive dependencies
PackageConstraintCompatibleLatest
convert-3.0.13.0.1
js-0.6.30.6.3
matcher-0.12.110.12.11
path-1.8.01.8.0
stack_trace-1.10.01.10.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Dart 2.14.3.

14
likes
130
pub points
93%
popularity

Publisher

appsup.be

A library for doing cryptographic signing/verifying and encrypting/decrypting.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

collection, meta, pointycastle, quiver

More

Packages that depend on crypto_keys