coverage 1.0.2
coverage: ^1.0.2 copied to clipboard

Coverage data manipulation and formatting

12
likes
90 / 130
pub points
98 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
0 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:9:1

  ╷
9 │ <a href="http://ltp.sourceforge.net/coverage/lcov.php">LCOV</a> or pretty-printed format.</p>
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

0/5 points: Provide a valid CHANGELOG.md

Links in `CHANGELOG.md` should be secure. 1 link is insecure.

CHANGELOG.md:249:9

    ╷
249 │ <li>Add <a href="http://bazel.io">Bazel</a> support to <code>format_coverage</code>.</li>
    │         ^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

Use https URLs instead.

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 22 out of 41 API elements (53.7 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:coverage/coverage.dart that imports:
  • package:coverage/src/run_and_collect.dart that imports:
  • package:coverage/src/util.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^2.0.02.0.02.0.0
logging^1.0.01.0.11.0.1
package_config^2.0.02.0.02.0.0
path^1.8.01.8.01.8.0
source_maps^0.10.100.10.100.10.10
stack_trace^1.10.01.10.01.10.0
vm_service^6.1.06.2.06.2.0
Transitive dependencies
PackageConstraintCompatibleLatest
collection-1.15.01.15.0
source_span-1.8.11.8.1
term_glyph-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.15.4, Dart 2.12.2.