country_code_picker 1.7.0
country_code_picker: ^1.7.0 copied to clipboard

Flutter Android iOS Linux macOS web Windows

A flutter package for showing a country code selector. In addition it gives the possibility to select a list of favorites countries, as well as to search using a simple searchbox

241
likes
100 / 110
pub points
98 %
popularity

We analyzed this package on Mar 9, 2021, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 29 out of 94 API elements (30.9 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: 'FlatButton' is deprecated and shouldn't be used. Use TextButton instead. See the migration guide in flutter.dev/go/material-button-migration-guide). This feature was deprecated after v1.25.0-8.1.pre..

lib/country_code_picker.dart:154:17

    ╷
154 │       _widget = FlatButton(
    │                 ^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/country_code_picker.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
modal_bottom_sheet^1.0.0+11.0.0+12.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.0+1` on modal_bottom_sheet does not support the stable version `2.0.0`, that was published 1 days ago.

When modal_bottom_sheet is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions modal_bottom_sheet to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.3, Flutter 2.0.0, Dart 2.12.0.

241
likes
100
pub points
98%
popularity

A flutter package for showing a country code selector. In addition it gives the possibility to select a list of favorites countries, as well as to search using a simple searchbox

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

salvatoregiordanoo@gmail.com

License

MIT (LICENSE)

Dependencies

flutter, modal_bottom_sheet

More

Packages that depend on country_code_picker