connectivity_plus_macos 1.2.6 icon indicating copy to clipboard operation
connectivity_plus_macos: ^1.2.6 copied to clipboard

PlatformmacOS

macOS implementation of the connectivity_plus plugin.

1.2.6 #

  • Discard unused warnings for switch reachability.connection ?? .unavailable in macOS by removing ?? .unavailable as left side of nil coalescing operator '??' has non-optional type 'Reachability.Connection', so the right side is never used.

1.2.5 #

  • Discard unused warnings for ensurePathMonitor & ensureReachability call in macOS.

1.2.4 #

  • Stop sending events once flutter engine detached

1.2.3 #

  • Send events on main thread

1.2.2 #

  • Fix connectivity stream can not be reused (after hot-restart) on MacOS 10.14+.

1.2.1 #

  • Update license headers.

1.2.0 #

  • Backport to macOS 10.11

1.1.0 #

  • Add ethernet as connectivity result.

    NOTE: The functionality is provided by NWPathMonitor, which is available since macOS 10.14. Therefore the minimum macOS deployment target has been changed from 10.11 to 10.14

1.0.2 #

  • Update connectivity plus

1.0.1 #

  • Improve documentation

1.0.0 #

  • Migrated to null safety

0.4.1 #

  • Address pub score

0.4.0 #

  • Removed members that were moved to network_info_plus

0.3.0 #

  • Updated platform interface

0.2.0 #

  • Transfer to plus-plugins monorepo

0.1.0+6 #

  • Transfer package to Flutter Community under new name connectivity_plus_macos.

0.1.0+5 #

  • Update package:e2e reference to use the local version in the flutter/plugins repository.

0.1.0+4 #

  • Remove Android folder from connectivity_macos.

0.1.0+3 #

  • Bump the minimum Flutter version to 1.12.13+hotfix.5.
  • Clean up various Android workarounds no longer needed after framework v1.12.
  • Complete v2 embedding support.
  • Fix CocoaPods podspec lint warnings.
  • Declare API stability and compatibility with 1.0.0 (more details at: https://github.com/flutter/flutter/wiki/Package-migration-to-1.0.0).

0.1.0+2 #

  • Remove hard coded ios workspace setting of the example app.

0.1.0+1 #

  • Make the pedantic dev_dependency explicit.

0.1.0 #

  • Adds an example app to trigger CI tests. Bumped the MINOR version to avoid compatibility issues once this packages is endorsed.

0.0.2+1 #

  • Add CHANGELOG.

0.0.1 #

  • Initial open source release.