code_builder 4.0.0
code_builder: ^4.0.0 copied to clipboard

A fluent, builder-based library for generating valid Dart code

65
likes
130 / 130
pub points
99 %
popularity

We analyzed this package on Jun 11, 2021, and awarded it 130 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 270 out of 566 API elements (47.7 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
built_collection^5.0.05.1.05.1.0
built_value^8.0.08.0.68.0.6
collection^1.15.01.15.01.15.0
matcher^0.12.100.12.100.12.10
meta^1.3.01.4.01.4.0
Transitive dependencies
PackageConstraintCompatibleLatest
fixnum-1.0.01.0.0
path-1.8.01.8.0
stack_trace-1.10.01.10.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.17.1, Dart 2.13.1.

65
likes
130
pub points
99%
popularity

Publisher

tools.dart.dev

A fluent, builder-based library for generating valid Dart code

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

built_collection, built_value, collection, matcher, meta

More

Packages that depend on code_builder