cloudbase_null_safety 1.1.3 icon indicating copy to clipboard operation
cloudbase_null_safety: ^1.1.3 copied to clipboard

Flutter plugin for cloudbase core. Temporary alternative to the official null-safety version, all APIs are consistent with the official.

7
likes
110/ 140
pub points
41%
popularity

We analyzed this package 10 hours ago, and awarded it 110 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 183 out of 777 API elements (23.6 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform Windows.

Because:

  • package:cloudbase_null_safety/cloudbase_null_safety.dart that declares support for platforms: Android, iOS.

Package does not support platform Linux.

Because:

  • package:cloudbase_null_safety/cloudbase_null_safety.dart that declares support for platforms: Android, iOS.

Package does not support platform macOS.

Because:

  • package:cloudbase_null_safety/cloudbase_null_safety.dart that declares support for platforms: Android, iOS.

Package does not support platform Web.

Because:

  • package:cloudbase_null_safety/cloudbase_null_safety.dart that declares support for platforms: Android, iOS.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 29 issues. Showing the first 2:

INFO: The import of 'package:cloudbase_null_safety/cloudbase_core/base.dart' is unnecessary because all of the used elements are also provided by the import of 'package:cloudbase_null_safety/cloudbase_null_safety.dart'.

lib/cloudbase_auth/baseAuth.dart:6:8

  ╷
6 │ import 'package:cloudbase_null_safety/cloudbase_core/base.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/cloudbase_auth/baseAuth.dart

INFO: The import of 'cache.dart' is unnecessary because all of the used elements are also provided by the import of 'package:cloudbase_null_safety/cloudbase_null_safety.dart'.

lib/cloudbase_auth/baseAuth.dart:9:8

  ╷
9 │ import 'cache.dart';
  │        ^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/cloudbase_auth/baseAuth.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
crypto^3.0.13.0.23.0.2
dio^4.0.04.0.64.0.6
flutterflutter0.0.00.0.0
package_info_plus^1.4.01.4.3+13.0.2
shared_preferences^2.0.72.0.152.0.15
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.10.02.10.0
characters-1.2.11.2.1
collection-1.16.01.17.0
ffi-2.0.12.0.1
file-6.1.46.1.4
flutter_web_plugins-0.0.00.0.0
http-0.13.50.13.5
http_parser-4.0.24.0.2
js-0.6.40.6.5
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
package_info_plus_linux-1.0.52.0.0
package_info_plus_macos-1.3.02.0.0
package_info_plus_platform_interface-1.0.22.0.1
package_info_plus_web-1.0.62.0.0
package_info_plus_windows-2.1.03.0.0
path-1.8.21.8.2
path_provider_linux-2.1.72.1.7
path_provider_platform_interface-2.0.52.0.5
path_provider_windows-2.1.32.1.3
platform-3.1.03.1.0
plugin_platform_interface-2.1.32.1.3
process-4.2.44.2.4
shared_preferences_android-2.0.142.0.14
shared_preferences_ios-2.1.12.1.1
shared_preferences_linux-2.1.12.1.1
shared_preferences_macos-2.0.42.0.4
shared_preferences_platform_interface-2.1.02.1.0
shared_preferences_web-2.0.42.0.4
shared_preferences_windows-2.1.12.1.1
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
vector_math-2.1.22.1.4
win32-3.1.23.1.2
xdg_directories-0.2.0+20.2.0+2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint ^1.4.0 on package_info_plus does not support the stable version 2.0.0.

Try running dart pub upgrade --major-versions package_info_plus to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.21, Flutter 3.3.9, Dart 2.18.5.

7
likes
110
pub points
41%
popularity

Publisher

unverified uploader

Flutter plugin for cloudbase core. Temporary alternative to the official null-safety version, all APIs are consistent with the official.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.unknown (LICENSE)

Dependencies

crypto, dio, flutter, package_info_plus, shared_preferences

More

Packages that depend on cloudbase_null_safety