cloudbase_null_safety 1.1.1
cloudbase_null_safety: ^1.1.1 copied to clipboard

Flutter plugin for cloudbase core. Temporary alternative to the official null-safety version, all APIs are consistent with the official.

flutter dart


cloudbase_null_safety | 腾讯云 Flutter CloudBase #

Latest Version

Pub

Flutter plugin for cloudbase core. Temporary alternative to the official null-safety version, all APIs are consistent with the official.

+ 1.1.0 version resolve the native platform [wxAuth] exception
+ 1.1.1 version resolve [!] No podspec found for cloudbase_null_safety in .symlinks/plugins/cloudbase_null_safety/ios

官方 Pub Package #

PackageNamePub Url
cloudbase_corePub
cloudbase_authPub
cloudbase_storagePub
cloudbase_functionPub

描述 & Description #

腾讯云·云开发的 Flutter 插件,更多的云开发 Flutter 插件请见云开发文档

此版本为官方空安全版本的临时替代包,用于升级空安全使用,所有官方API不变,直接替换使用.

(官方)非空安全版本

已迁移的包:

  • [x] cloudbase_core
  • [x] cloudbase_storage
  • [x] cloudbase_auth
  • [x] cloudbase_function
  • [ ] cloudbase_database

安装 #

在 flutter 项目的 pubspec.yaml 文件的 dependencies 中添加

dependencies:
  cloudbase_null_safety: Latest

简单示例 #

import 'package:cloudbase_null_safety/cloudbase_null_safety.dart';

// 初始化 CloudBase
CloudBaseCore core = CloudBaseCore.init({
    // 填写你的云开发 env
    'env': 'your-env-id'
});

详细文档 #

云开发·初始化

2
likes
120
pub points
43%
popularity

Flutter plugin for cloudbase core. Temporary alternative to the official null-safety version, all APIs are consistent with the official.

Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

crypto, dio, flutter, package_info, shared_preferences

More

Packages that depend on cloudbase_null_safety