built_value_generator 7.1.0

Dart native

Value types with builders, Dart classes as enums, and serialization. This library is the dev dependency.

40
likes
100 / 110
pub points
92 %
popularity

We analyzed this package on Aug 11, 2020, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 6 API elements (33.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:built_value_generator/built_value_generator.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer>=0.39.3 <0.40.00.39.160.39.16
build^1.0.01.3.01.3.0
build_config>=0.3.1 <0.5.00.4.20.4.2
built_collection>=2.0.0 <5.0.04.3.24.3.2
built_value>=7.0.0 <7.2.07.1.07.1.0
quiver>=0.21.0 <3.0.02.1.32.1.3
source_gen^0.9.00.9.60.9.6
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-6.0.06.0.0
args-1.6.01.6.0
async-2.4.22.4.2
charcode-1.1.31.1.3
checked_yaml-1.0.21.0.2
cli_util-0.1.40.2.0
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
csslib-0.16.20.16.2
dart_style-1.3.61.3.6
fixnum-0.10.110.10.11
glob-1.2.01.2.0
html-0.14.0+30.14.0+3
js-0.6.20.6.2
json_annotation-3.0.13.0.1
matcher-0.12.90.12.9
meta-1.2.21.2.2
node_interop-1.1.11.1.1
node_io-1.1.11.1.1
package_config-1.9.31.9.3
path-1.7.01.7.0
pub_semver-1.4.41.4.4
pubspec_parse-0.1.50.1.5
source_span-1.7.01.7.0
stack_trace-1.9.51.9.5
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
watcher-0.9.7+150.9.7+15
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

40
likes
100
pub points
92%
popularity

Publisher

dart.dev

Value types with builders, Dart classes as enums, and serialization. This library is the dev dependency.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

analyzer, build, build_config, built_collection, built_value, quiver, source_gen

More

Packages that depend on built_value_generator