build_daemon 3.0.1
build_daemon: ^3.0.1 copied to clipboard

A daemon for running Dart builds.

3
likes
110/ 130
pub points
97%
popularity

We analyzed this package 41 hours ago, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 57 out of 218 API elements (26.1 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:build_daemon/change_provider.dart that imports:
  • package:watcher/watcher.dart that imports:
  • package:watcher/src/file_watcher/polling.dart that imports:
  • package:watcher/src/stat.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
built_collection^5.0.05.1.15.1.1
built_value^8.0.08.1.38.1.3
http_multi_server^3.0.03.0.13.0.1
logging^1.0.01.0.21.0.2
path^1.8.01.8.01.8.0
pool^1.5.01.5.01.5.0
shelf^1.0.01.2.01.2.0
shelf_web_socket^1.0.01.0.11.0.1
stream_transform^2.0.02.0.02.0.0
watcher^1.0.01.0.11.0.1
web_socket_channel^2.0.02.1.02.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
charcode-1.3.11.3.1
collection-1.15.01.15.0
crypto-3.0.13.0.1
fixnum-1.0.01.0.0
http_parser-4.0.04.0.0
meta-1.7.01.7.0
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Dart 2.15.0.