boolean_selector 2.1.0
boolean_selector: ^2.1.0 copied to clipboard

A flexible syntax for boolean expressions, based on a simplified version of Dart's expression syntax.

example/example.dart

import 'package:boolean_selector/boolean_selector.dart';

void main(List<String> args) {
  var selector = BooleanSelector.parse('(x && y) || z');
  print(selector.evaluate((variable) => args.contains(variable)));
}
3
likes
130
pub points
98%
popularity

A flexible syntax for boolean expressions, based on a simplified version of Dart's expression syntax.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploaders

nweiz@google.com
kevmoo@google.com
nbosch@google.com
jakemac@google.com

License

BSD (LICENSE)

Dependencies

source_span, string_scanner

More

Packages that depend on boolean_selector