angular_sentry 0.1.0 icon indicating copy to clipboard operation
angular_sentry: ^0.1.0 copied to clipboard

Platformweb

Helper to implements sentry with Angular

1
likes
130/ 140
pub points
60%
popularity

We analyzed this package 9 hours ago, and awarded it 130 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 11 API elements (36.4 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Web

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:angular_sentry/angular_sentry.dart that imports:
  • package:angular/angular.dart that imports:
  • package:angular/src/testability.dart that imports:
  • package:angular/src/testability/testability.dart that imports:
  • package:angular/src/testability/js_api.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Package not compatible with platform iOS

Because:

  • package:angular_sentry/angular_sentry.dart that imports:
  • package:angular/angular.dart that imports:
  • package:angular/src/testability.dart that imports:
  • package:angular/src/testability/testability.dart that imports:
  • package:angular/src/testability/js_api.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Package not compatible with platform Windows

Because:

  • package:angular_sentry/angular_sentry.dart that imports:
  • package:angular/angular.dart that imports:
  • package:angular/src/testability.dart that imports:
  • package:angular/src/testability/testability.dart that imports:
  • package:angular/src/testability/js_api.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Package not compatible with platform Linux

Because:

  • package:angular_sentry/angular_sentry.dart that imports:
  • package:angular/angular.dart that imports:
  • package:angular/src/testability.dart that imports:
  • package:angular/src/testability/testability.dart that imports:
  • package:angular/src/testability/js_api.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Package not compatible with platform macOS

Because:

  • package:angular_sentry/angular_sentry.dart that imports:
  • package:angular/angular.dart that imports:
  • package:angular/src/testability.dart that imports:
  • package:angular/src/testability/testability.dart that imports:
  • package:angular/src/testability/js_api.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angular^7.0.07.0.27.0.2
logging^1.0.01.1.01.1.0
meta^1.1.01.8.01.8.0
sentry^6.0.06.19.06.19.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-31.0.052.0.0
analyzer-2.8.05.4.0
angular_ast-2.0.12.0.1
angular_compiler-2.0.22.0.2
args-2.3.22.3.2
async-2.10.02.10.0
boolean_selector-2.1.12.1.1
build-2.3.12.3.1
build_config-1.1.11.1.1
build_resolvers-2.0.62.1.0
build_test-2.1.62.1.6
built_collection-5.1.15.1.1
built_value-8.4.38.4.3
charcode-1.3.11.3.1
checked_yaml-2.0.22.0.2
cli_util-0.3.50.3.5
clock-1.1.11.1.1
code_builder-4.4.04.4.0
collection-1.17.01.17.0
convert-3.1.13.1.1
coverage-1.3.21.6.2
crypto-3.0.23.0.2
csslib-0.17.20.17.2
dart_style-2.2.12.2.4
file-6.1.46.1.4
fixnum-1.0.11.0.1
frontend_server_client-2.1.33.2.0
glob-2.1.12.1.1
graphs-2.2.02.2.0
html-0.15.10.15.1
http-0.13.50.13.5
http_multi_server-3.2.13.2.1
http_parser-4.0.24.0.2
intl-0.17.00.18.0
io-1.0.41.0.4
js-0.6.60.6.6
json_annotation-4.8.04.8.0
matcher-0.12.110.12.14
mime-1.0.41.0.4
node_preamble-2.0.12.0.1
package_config-2.1.02.1.0
path-1.8.31.8.3
pedantic-1.11.11.11.1
pool-1.5.11.5.1
pub_semver-2.1.32.1.3
pubspec_parse-1.2.11.2.1
quiver-3.2.13.2.1
shelf-1.4.01.4.0
shelf_packages_handler-3.0.13.0.1
shelf_static-1.1.11.1.1
shelf_web_socket-1.0.31.0.3
source_gen-1.2.21.2.6
source_map_stack_trace-2.1.12.1.1
source_maps-0.10.110.10.11
source_span-1.9.11.9.1
stack_trace-1.11.01.11.0
stream_channel-2.1.12.1.1
stream_transform-2.1.02.1.0
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
test-1.20.21.22.2
test_api-0.4.90.4.18
test_core-0.4.110.4.22
typed_data-1.3.11.3.1
uuid-3.0.73.0.7
vm_service-8.3.010.1.0
watcher-1.0.21.0.2
web_socket_channel-2.3.02.3.0
webkit_inspection_protocol-1.2.01.2.0
yaml-3.1.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Dart 2.19.0.

1
likes
130
pub points
60%
popularity

Publisher

unverified uploader

Helper to implements sentry with Angular

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

angular, logging, meta, sentry

More

Packages that depend on angular_sentry