angular_redux_dev_tools 0.2.0

  • Readme
  • Changelog
  • Installing
  • 0

angular_redux_dev_tools #

Build Status

An AngularDart component you can use to show a Redux Time Travel UI.

Usage #

Add imports for DevToolsStore and ReduxDevToolsComponent:

import 'package:angular_redux_dev_tools/redux_dev_tools_component.dart';
import 'package:redux_dev_tools/redux_dev_tools.dart';
  • Add ReduxDevToolsComponent to your component's directives
  • Create a <redux-dev-tools> element
  • Bind a DevToolsStore to the store property
  selector: 'my-example',
  template: '<redux-dev-tools [store]="store"></redux-dev-tools>',
  directives: const [ReduxDevToolsComponent],
class ExampleComponent {
    final DevToolsStore store = new DevToolsStore(exampleReducer);

Note: This Widget does not work with a normal Redux Store. It is meant to work with the redux_dev_tools package, which provides a DevToolsStore. The DevToolsStore is a drop-in replacement for your Store during Development!

Demo #

Vanilla counter demo

Vanilla counter demo video

Example #

To launch the examples in your browser:

Credits #

All of this is inspired by the original Redux Devtools. and Flutter Redux Devtools.

Changelog #

0.2.0 #

  • Fully tested and code-commented release.

0.1.0 #

  • Displays state in multi-select menu with SAVE, RESET, RECOMPUTE, and GOTO buttons.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  angular_redux_dev_tools: ^0.2.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:angular_redux_dev_tools/angular_redux_dev_tools.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.0 <2.0.0